ICONICO

Discussion Thread

UniToolbox

Message Thread

Developer ComponentFor WindowsUniToolbox

UniToolbox iconThe leading control suite for Unicode development in Visual Basic.

Posted in the UniToolbox Forum.




labels disappear when not pointed correctly

I have a question, i am using Unitoolbox which i purchase online and i always encounter this problem. When i accidentally click somewhere from the interface not directly pointed to the exact button or links all the labels are gone and cannot be seen but to make it visible again you need to click on the other links then go back to where you encounter the problem then its there again.

Why is this thing happen? how can i correct this problem. Please reply.

thanks.
by joey on Mar 1 2009 3:58am Reply

labels disappear when not pointed correctly

Thanks for the post, but I'm not understanding the problem, could you post a screenshot or email one to nico [at] iconico [dot com]
by Nico Westerdale on Mar 1 2009 11:10am Reply

labels disappear when not pointed correctly

I believe he meant when all the labels disappeared when he clicked at any items in the form. I found that problems sometimes when I use Unilabel with transparent backstyle.

Try to choose the labels backstyle to 'opaque' instead of 'transparent' and see if it fixes.
by Panik on Mar 11 2009 10:55pm Reply

labels disappear when not pointed correctly

I'd better add steps to reproduce for Nico in case that he'd like to fix it.
1. Create a form
2. Add Unilabel with transparent backstyle
3. add icon "btndisappear"
4. add function
Private Sub btndisappear_Click()
UniLabel.FontBold = True
Refresh
End Sub
5. Test it.You will see the Unilabel mysteriously disappears in an instant ;)
by on Mar 11 2009 11:23pm Reply

labels disappear when not pointed correctly

Sorry for triple poses. In case that you guy had the exact same problem as me. Here is my work around (Do not ask me why it worked cause I got no idea either :P) :

-every time you need to update the Unilabel with transparent backstyle.... Reset the transparent and then refresh. Like this:

UnilabelA.BackStyle = Transparent
Refresh

Hope this helps
by Panik on Mar 11 2009 11:52pm Reply

labels disappear when not pointed correctly

Looks like that solves the issue, thanks for the help!
by Nico Westerdale on Mar 12 2009 2:17am Reply

labels disappear when not pointed correctly

thank you all guys for all your help. i'll get back to that problem to fix soon, right now i have another posting about the imemode or the half-width alphanumeric default, is
anybody there have an idea about these. anyway i posted already the problem from the other thread here. thanks
by joey on Mar 21 2009 11:12pm Reply

Our Software Stores

IconicoAccurate Design and Development Software

BitsDuJourDiscount Deal Coupons for Windows and Mac Software Apps

Our Software Services

IcoBlogOur Official Blog

© copyright 2004-2021 Iconico, Inc. Code & Design. All Rights Reserved. Terms & Conditions Privacy Policy Terms of Use Login